Category talk:Alan games

From IFWiki
Jump to: navigation, search

Alan interpreters

Would it be useful to make clear that (just like ADRIFT, but unlike TADS, for instance) you must use different interpreters to play games written with Alan 2 and Alan 3? It wasn't obvious for me, the first time I tried to play an Alan 2 game (and indeed an ADRIFT 3.90 game, too...) --Eriorg 13:04, 20 December 2006 (EST)

Yeah, that probably would be a nice bit to add in there. And I'm sure that there are older TADS interpreters that can only handle TADS 2 games. (Reasonably sure, anyway. It's not something I've tested.) -- David Welbourn 13:13, 20 December 2006 (EST)

Maybe there are such TADS interpreters, but that's not the same problem: if you use the latest interpreters (at least, HTML TADS on Windows is like that), you can play both TADS 2 and TADS 3 games without any problems. If you use the latest Alan 3 (or ADRIFT 4) interpreter, you can't play Alan 2 (or ADRIFT 3.90) games at all with it! And the older interpreters were not quite as easy to find on the official websites as the new ones, if I remember correctly. --Eriorg 13:37, 20 December 2006 (EST)

Okay, I added a line to the category page. Does it look okay to you now? -- David Welbourn 14:03, 20 December 2006 (EST)

That's fine. Thank you!--Eriorg 14:08, 20 December 2006 (EST)